Budgetphone werkt niet met Asterisk 1.8.8.x

Speciaal voor Asterisk-gebruikers een apart forum voor Budget Phone accounts.
Plaats reactie
Bericht
Auteur
AutoStatic
Berichten: 11
Lid geworden op: vr 27 jan 2012, 23:11

Budgetphone werkt niet met Asterisk 1.8.8.x

#1 Bericht door AutoStatic » vr 27 jan 2012, 23:43

Heb Budgetphone getest met 1.8.8.1 en 1.8.8.2 en met beide versies lukt het me niet te registreren bij Budgetphone. Ik krijg timeouts:

Code: Selecteer alles

Registration for '31xxxxxxxxx@sip1.budgetphone.nl' timed out, trying again
Als ik vervolgens ngrep draai zie ik een 400: Bad From header voorbijkomen. Heb de header gecheckt en kennelijk verslikt de Budgetphone SIP server zich in de line break in de From headers voor de >:

Code: Selecteer alles

...
From: <sip:31xxxxxxxxx@sip1.budgetphone.nl
>;tag=...
Heb nu Asterisk 1.6.2.9 geïnstalleerd (pakketje van Debian Squeeze) en registratie gaat nu feilloos. Zie ook met ngrep dat er géén line breaks in de registratie request zitten. Ik zie nu hier dat mensen gelijksoortige problemen hebben, oplossing kan dus zijn om een oudere of nieuwere versie van Asterisk te gebruiken. En wellicht helpt het Budgetphone te contacten hierover, lijkt me dat ze hier wel wat aan kunnen doen omdat het misschien aan de door hun gebruikte SIP software kan liggen (voor zover ik kan zien een al wat oudere versie van OpenSIPS).

AutoStatic
Berichten: 11
Lid geworden op: vr 27 jan 2012, 23:11

Re: Budgetphone werkt niet met Asterisk 1.8.8.x

#2 Bericht door AutoStatic » di 14 feb 2012, 22:36

Met 1.8.9.x werkt het weer wel.

Plaats reactie